GitHub header

AU - Disruption with some GitHub services

Incident Report for GitHub Enterprise Cloud Australia

Resolved

On July 2nd, 2025, between approximately 08:40 and 10:16 UTC, the Copilot service experienced degradation due to an infrastructure issue which impacted the Claude Sonnet 4 model, leading to a spike in errors. No other models were impacted.

The issue was mitigated by rebalancing load within our infrastructure. GitHub is working to further improve the resiliency of the service to prevent similar incidents in the future.
Posted Jul 02, 2025 - 10:16 UTC

Update

We are no longer experiencing degradation—Claude Sonnet 4 is once again available in Copilot Chat and across IDE integrations.

We will continue monitoring to ensure stability, but mitigation is complete.
Posted Jul 02, 2025 - 10:16 UTC

Investigating

We are currently investigating this issue.
Posted Jul 02, 2025 - 09:57 UTC